m-Power System Requirements

 

Prior to installing m-Power, please be sure that the following requirements have been met.

*64-bit servers are highly recommended as they support more RAM than 32-bit servers.*

m-Power End-User Client Requirements
Web Browser Microsoft Internet Explorer
Internet Explorer 11 or later
Firefox
Firefox Version 40.0 or later
Chrome
Chrome Version 40.0 or later
Safari
Safari Version 4.0 or later
m-Power Production Server Requirements
Server Operating System Microsoft
Microsoft Windows 7 — 64-bit recommended
Microsoft Vista — 64-bit recommended
Windows XP — 64-bit recommended
Microsoft Server 2003 or later — 64-bit recommended
IBM
System i, V5R4 or later
Java Developer Kit (JDK) JDK 1.8 (Pre-configured)
Apache Tomcat Tomcat Version 7 (Pre-configured)
Database MS SQL 2005 or later
MYSQL
Oracle 10g or later
Progress
postgreSql
DB2 for Windows
DB2 for System i
Memory 4 gigabytes recommended
Processor 2.5 GHz recommended
System disk space 2 gigabyte recommended
Tomcat as a Service Required — Click here for more information
Tomcat configured to reload Encouraged to set to false — Click here for more information
m-Power Development Server Requirements
Server Operating System Microsoft
Microsoft Windows 7 — 64-bit recommended
Microsoft Vista — 64-bit recommended
Windows XP — 64-bit recommended
Microsoft Server 2003 or later — 64-bit recommended
IBM
System i, V5R4 or later
Java Developer Kit (JDK) JDK 1.8 (Pre-configured)
Apache Tomcat Tomcat Version 7 (Pre-configured)
Database MS SQL 2005 or later
MYSQL
Oracle 10g or later
Progress
postgreSql
DB2 for Windows
DB2 for System i
Memory 3 gigabytes recommended
Processor 2 GHz recommended
System disk space 1 gigabyte recommended
Tomcat as a Service Required — Click here for more information
Tomcat configured to reload Required to set to true (Pre-configured)
m-Power Developer Client Requirements
Web Browser Microsoft Internet Explorer
Internet Explorer 11 or later
Mozilla Firefox
Firefox 40.0 or later
Google Chrome
Chrome 40.0 or later
Apple Safari
Safari 4.0 or later

 

Created: October 11, 2011 | Modified: June 12, 2017