m-Painter Manual

Introduction

After building an application, you have the opportunity to open m-Painter and modify the look and the feel of your HTML presentation layer. In addition, you will be able to edit the pages in a WYSIWYG environment (What You See Is What You Get). This means, no more looking at hundreds of lines of HTML to create your pages!

You can access m-Painter in two different ways:

  1. From the Manage Applications screen, click the icon next to the appropriate application.
  2. From the "Build & Compile" screen, click this button:

Note: The application has to have been compiled to access m-Painter.

Below is a screen shot of a freshly compiled multiple record inquiry opened in m-Painter:

The m-Painter Toolbar

As can be seen, the m-Painter toolbar groups all functions together in tabs and menus.

File menu — This menu contains:

  • Open File — Opens a window that allows you to easily find and open another file associated with the current application such as a report prompt page, the application's Java file, or mobile device and separate language presentation layers.

    Note: Not all output choices are supported by the WYSIWYG feature.

  • Execute — Runs the current application in a new window.
  • Save As — Opens a prompt to save a copy of the current application page with a unique name. After a successful save, this newly named page will be opened for immediate editing. For more information regarding page name functionality, click here.
  • Versions — Opens a window which lists all previous saved versions of the current application's page. After clicking this button, the following window will be seen:

    All previous versions are listed in the top dropdown, along with date saved, user who saved the page, and if this was generated by m-Power's compile process. Versions can also be deleted by clicking the red X next to each one. Once a version is selected, it will be displayed in the center of the window as shown below:

    The source button can also be clicked to view any inline or code changes that are not easily seen in WYSIWYG mode. If this is the desired version, click OK and confirm that you would like to replace the current version.

    Note: As long as the current version has been saved, it can be retrieved from the Versions window using the same method.

    Note: There are no limits to the number of revisions saved. Unless manually deleted, every version of the current page will be available in this list.

  • Revert — (Only available in Source mode) Undo any changes caused by saving or toggling between source and WYSIWYG mode. After clicking, the changes that have been reverted are highlighted as seen below:

View menu — This menu contains:

  • Design — When not in Design mode, opens the WYSIWYG mode for easy editing.
  • Source — When not in Source mode, opens the current html file in a color-coded text editor.

Edit menu — This menu contains:

  • Find — (Only available in source mode) Search for key words within the HTML source view.
  • Cut — Cut selected text, images, and fields.
  • Copy — Copy selected text, images, and fields.
  • Paste — Paste selected text, images, and fields.

Help menu — This menu contains:

  • m-Painter Docs — This opens the online manual to the section about m-Painter for reference or to answer any particular questions you may encounter.
  • FAQ — This opens the frequently asked questions area of the m-Power website.
  • Customer Portal — This opens the customer portal for submitting helpdesk questions, enhancement requests, or to download the latest version of m-Power.

    Note: This link requires your customer sign-in information.

Insert tab — This tab contains:

  • Save — This saves your changes to the server.

    Note: This is available on all three tabs.

  • Undo & Redo — Undo and redo, respectively, any recent changes.

    Note: This is available on all three tabs.

  • Link — Inserts a new link or edits an existing link. After selecting a field/text, you will be able to click on this button to add a hyperlink. Full documentation on inserting and editing links can be found here.
  • Image — Adds an image to the current presentation layer from a file on your computer or a web address. The default folder is /mrcjava/image.
  • Table — Adds a table to the current presentation layer. When right-clicking on a pre-existing table, m-Power lets you edit some characteristics of the table.
  • Field — Adds selected fields and common properties into your application, in addition to the fields that already exist.

    Note: In Reports, you have the ability to select the level of the field (Detail, Last Row of Detail, Subtotal, or Grand Total level).

  • Calc — (Only available in Reports) Inserts a runtime calculation. Runtime calculations are most useful when trying to determine averages on sub-total or grand-total lines. See this link for more information.
  • Graph — (Only available in Report templates that include a graph) Inserts a new graph or updates the settings for an existing graph. See this link for more information.
  • Import — This allows you to bring multiple applications into one application. You can import whole applications or single pieces of information, such as fields. See this link for more information.
  • Map — Inserts a new Google Map or updates an existing Google Map. This feature lets you integrate a live Google Map into your application. See this link for more information.
  • Widget — Inserts a widget into the presentation layer or updates the widget already in the presentation layer. This feature allows you to better organize your on-screen data. See this link for more information.

Inputs tab — This tab contains:

  • Save — This saves your changes to the server.

    Note: This is available on all three tabs.

  • Undo & Redo — Undo and redo, respectively, any recent changes.

    Note: This is available on all three tabs.

  • Option List — Creates a drop-down list, radio buttons, button list, or checkboxes for a text input in the current presentation layer. It can only be selected after you have selected an input box. Selecting an existing option list also allows the opportunity to change or remove the option list. See this link for more information.
  • Calendar — Inserts a calendar picker to a text input or updates an existing one. This feature is available when any input box is selected and allows end-users to select a date rather than type it themselves. See this link for more information.
  • Lookup — Inserts a new lookup window or updates an existing one. This feature is a great alternative to dropdown lists for end-users who need to choose from hundreds to thousands of records. See this link for more information.
  • AJAX — (Not available in Retrievals) Inserts a built-in AJAX feature to the current presentation layer. This feature allows you to add the ability for this application to connect to the server without a user directly submitting a form. See this link for more information.

Formatting tab — This tab contains:

  • Save — This saves your changes to the server.

    Note: This is available on all three tabs.

  • Undo & Redo — Undo and redo, respectively, any recent changes.

    Note: This is available on all three tabs.

  • Styles — Applies a preset style to the selected field or text. To use, first highlight the desired text or left click on the field. Then, select a style from this dropdown to automatically style the selection.
  • Format — Applies a paragraph format to the selected text or field. To use, first highlight the desired text or left click on the field. Then, select a paragraph format from this dropdown to automatically format the selection.
  • Font — Applies a different font to the selected text or field. To use, first highlight the desired text or left click on the field. Then, select the desired font name from this dropdown to automatically format the selection.
  • Font Size — Applies a different font size to the selected text or field. To use, first highlight the desired text or left click on the field. Then, select the desired font size from this dropdown to automatically format the selection.
  • Text Color — Applies a different text color to the selected text or field. To use, first highlight the desired text or left click on the field. Then, select the desired text color from this dropdown to automatically format the selection.
  • Background Color — Applies a different background color to the selected text or field. To use, first highlight the desired text or left click on the field. Then, select the desired background color from this dropdown to automatically format the selection.
  • Bold, Italic, & Underline — Applies font formatting of bold, italics, or underline respectively. To use, first highlight the desired text or left click on the field. Then, select the desired option from these three buttons to automatically format the selection.

    Note: To remove this formatting, highlight the text or left click on the field and unselect the button.

  • Numbered List & Bulleted List — Adds an ordered or unordered list to the current presentation layer. To use, left click where the list is desired and then click one of these buttons. To remove, left click where the current list is and then click the appropriate button.
  • Left, Center, & Right Justify — Changes the positioning of your text. To use, highlight text or left click on a field and then select the appropriate justification desired.

    Note: This new text positioning is relative to the container the text is in, i.e. a field value will be center justified relative to the table cell that contains this field value.

Context Menu

There are several features that can be accessed directly within the WYSIWYG mode of m-Painter by right-clicking on certain objects, which will open m-Painter's context menu, as shown below:

When you
right-click on:
You will see:
(Hover over the menu to see more information)
Sub-menu?
(Hover over the sub-menu to see more information)
Anything

name="row">

Selected Text
or Field Value

Radio, Checkbox,
Button, etc.

OR

Text Input

Link

Graph

Image

Supported Browsers

m-Painter currently supports the following browsers:

Internet Explorer 11 +
Google Chrome Version 40+
Mozilla Firefox Version 40+

Created: February 29, 2008 | Modified: August 22, 2017